Applies To:
  • CitectSCADA 6.00, 6.1, 7.0
  • CitectHMI 6.00, 6.1, 7.0

After starting my WebClient I receive a Software Protection error.

For CitectSCADA V6.0 & V6.1

Ensure that your computer setup wizard shows your configuration is selected as a "network computer" in your Computer Setup Wizard / Computer Role Setup.  And that your configuratoin is NOT set as a "Stand-alone Computer".

Enable pure TCP/IP (disabling NetBIOS by adding [LAN]NetBIOS=0 to CITECT.INI file) and define the IP address for each of your Primary and Standby servers in your [DNS] section of your Citect.ini file. Please see KB article Q3725 for configuration information on setting up [DNS].

Redeploy your project from Citect Explorer and Update Changes from Internet Explorer. Start CitectSCADA Runtime. Start WebClient.

For CitectSCADA V7.0

Ensure TCP/IP is selected in the Computer Setup Wizard. Also, ensure that you have your Static IP Address Defined in the Project Editor / Servers / Network Addresses form and that this same address is used on your Servers.  Ensure that you are NOT using the loopback IP Address of for your Network Addresses form, as this will produce the same problem described in the Summary above.  Also ensure that your WebClient IP Address is on the same Subnet as your IOServer PC.  If you are crossing a subnet then you will need to configure the [AddressFowarding] section in your Citect.ini file as per KB Q4946.  If your IOServer has a 2nd Network Card (NIC) then you will be able to configure a Second Network Address to be used only for Webclient Access as per the configuratoin in the Picture Below:



Display, WebClient, WebServer, Server, Web Server, Web Client , Key, Dual NIC