Proficy Portal 2.5 Connectors

The following table outlines the compatibility of Proficy Portal with other products:

Connector

Requirements

Alarms

iFIX - the local iFIX iClient install should be updated with the most recent iFIX General SIM. The SCADA nodes in the iClient remote nodes list should also have the most recent SIM.

CIMPLICITY HMI Logger

Supported versions:

  • 5.0

  • 5.5

  • 6.0

  • 6.1

iHistorian

Supported Historian versions: 1.0, 2.0, 3.0 or greater.

Install the Historian client to the Proficy Portal server and update the installation with the most recent Historian General SIM. If you are connecting to both Historian version 1 and 2 servers, install the higher version of the Historian client to the Proficy Portal server.

PI

Supported PI-API versions: 1.2.3.4 to 1.3.4.

Plant Database

Supported Plant Applications versions: 4.2 or greater.

VisualSPC

Supported Shop Floor SPC versions: 4.6, 5.03, 5.5.

CIMPLICITY HMI

At the time of release, the following versions/updates are required:

  • 5.0 - Service Pack 4 with Update 042204_IA_504

  • 5.5 - Service Pack 2 with Update 042204_IA_5502

  • 6.0 - Service Pack 3 with Update 042204_IA_603

  • 6.1 - Service Pack 2

For newer updates, check the web site (see link at the bottom of this table) for CIMPLICITY/Proficy Portal connectivity updates.

FIX

Supported iFIX versions: 3.0 or greater on the Proficy Portal server machine

NOTE: The iFIX connector on the Proficy Portal machine can communicate with any SCADA server that iFIX 3.0+ can communicate with, such as iFIX 2.1 and FIX 6.15 - 7.0.

iClient must be installed to the Proficy Portal server. iFIX 2.6 and 3.0 require a SIM for trend data.

OPC

Supported versions: any 1.0 compliant server.

SQL

  • GE Fanuc DB2 supported versions: DB2 UDB for Windows, UNIX, Linux, Linux/s390 v7.1, v7.2, v8.1, DB2 UDB for OS/390 v7, DB2 UDB for z/OS and OS/390 v7, DB2 UDB for AS/400 4R5, V5R1, V5R2.

  • GE Fanuc SQL supported versions: MS SQL Server 7.0, MS SQL Server 2000 (including service packs 1, 2, and 3), MS SQL Server 2000 Enterprise Edition (64-bit).

  • GE Fanuc Oracle supported versions: Oracle 8i R2-R3 (8.1.6-8.1.7), Oracle 9i R1-R2.

  • ODBC, ADO.

For the latest iFIX, FIX32, and Historian downloads, visit:

http://globalcare.gefanuc.com/downloads/ sims/

For the latest CIMPLICITY downloads, visit:

http://www.geindustrial.com/cwc/gefanuc/support/AutomationSoftware/cimplicity-d.htm