There are some details about setting up a product and browser for the Internet that even the most experienced system administrator may forget to do. If that happens to you, a user may run into problems..
Following are some problems that you may encounter when you set up your system to run on the web. Each problem comes with descriptions of possible causes and solutions.
Problem |
The URL cannot be found when a user tries to go to the WebView Intranet address. |
Cause |
Your browser is using a proxy server. |
Solution |
Open the Browser Properties dialog box and turn off (bypass) the proxy server for local networks or specifically for the computer that functions as the Web server. |
Cause |
The DNS naming is not set up properly so the host name is not resolved properly. |
Solution |
Use the IP address of the server instead of the computer name of the server. If that works, you will know that there is a problem with the name resolution in the network configuration. |
Cause |
A user uses incorrect syntax to go to the WebView address. For example a user: Uses backslashes (\) instead of front slashes (/), or Types an entire path (http://C:\Path\computername) instead of simply the computer name (http://computername/ ) |
Solution |
Provide the user with the exact address that should be entered, for example, http://computername. |
Problem |
A connection to the server cannot be made when a user tries to go to the WebView Intranet address. |
Cause |
WebView was not started. |
Solution |
Open the CIMPLICITY Options dialog box; select the WebView tab; start WebView. |
Problem |
The user displays an inactive CimView screen through the browser. |
Cause |
The CIMPLICITY project is not running. |
Solution |
Start the CIMPLICITY project. |
Problem |
Seconds are not displayed in the log file. |
Cause |
In Excel, the Time column's display style is not formatted to display seconds. |
Solution |
The seconds are in the log file. If you are displaying the log file using Microsoft Excel, change the format for the time column's style to display seconds. |
Problem
|
The following error messages display in the status bar of the browser. They are saying that the Java applet did not get loaded or displayed. load: class com.gefanuc.hmi.ProwlerClientApplet not found (in Internet Explorer). Applet com.gefanuc.hmi.ProwlerClient.ProwlerClientApplet class com.gefanuc.hmi.ProwlerClient.ProwlerClientApplet could not be loaded (in Netscape Navigator) |
Cause |
The ProwlerClient.jar file is not in the Web server's root directory |
Solution |
Copy the ProwlerClient.jar file from the WebPages directory in (a subdirectory in the CIMPLICITY directory) to the Web server's root directory. |
Cause |
You double clicked on an HTML file in the WebPages directory. |
Solution |
Access the Web page through the Web server (http://server/). |
Problem
|
The error message "Failed to connect to computer:10212." appears in the Java applet window. |
Cause |
The Web server is not running on the same computer as the WebView server |
Solution |
Configure the Web server to run on the same computer as the WebView server |
Cause |
The WebView server is not running. |
Solution |
Display the WebView tab in the CIMPLICITY Options dialog box and start the WebView server. |
Problem |
A user has difficulty trying to print CimView screens through the browser. |
Solution |
A user can Alt+PrintScreen to copy the bitmap of the window to the clipboard and then print it using some other application such as Paint, Microsoft Word, Microsoft Photo Editor, etc. |
Problem |
Most Web servers listen on port 80 for requests from browsers. Only one server at a time may listen on that port. If you try to use the CIMPLICITY built in Web server and you have another Web server running, you may get a warning in the CIMPLICITY Options dialog.
You may encounter this message if you have both CIMPLICITY and CIMPLICITY Machine Edition installed. |
Solution |
There are four basic ways to resolve this conflict.
More information about third part Web servers.
Fully qualified links in Web pages will need to be modified as well, but links that don't specify the computer name will not need to be changed (for example, http:/WebView/overview.html)
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Problem |
A WebView client displays incorrect delimiters when it logs on to a server hosting a different locale. For example, if a number such as 6.0010.1 is set on a server in a German locale, and the WebView logs on in an English locale. The number may display as 6.0010,1, which is incorrect. |
Solution |
Both the WebView client and server have to run the same locale in order for a WebView screen to display localized delimiters on the client computer. |
WebView easy steps. |
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WebView advanced configuration. |
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About WebView. |